交换机及其配置心得交流

网络 路由交换
作为局域网的主要连接设备,以太网交换机成为应用普及最快的网络设备之一,我们要怎么配置交换机呢?

局域网交换机基本功能:

(1) 建立和维护一个表示 MAC 地址与交换机端口对应关系的交换表

(2) 发送结点和接收结点之间建立一条虚连接

(3) 完成数据帧的转发或过滤

显示交换机命令: 大中型交换机:show cam dunamic 小型交换机:show mac-address-table

交换机的交换结构

(1) 软件执行交换结构(把数据帧由串行代码转换成并行代码)特点:交换速度慢,交换机堆叠困难,交换机端口较多导致性能下降

(2) 矩阵交换结构(完全由硬件完成,由输入,输出,交换矩阵和控制处理) 特点:交换速度快,延时小,结构紧凑,矩阵交换实现相对简单,不易扩展,不利于管理

(3) 总线交换结构(时分多路复用技术)特点:性能好,便于堆叠扩展,易实现帧广播和监控管理,易实现多个输入对一个输出的帧传送的特点。 应用广泛

(4) 共享存储器交换结构(无背板)特点:结构简单,易实现适合小交换机采用

交换机有静态交换和动态交换两种方式,动态交换模式有存储转发和直通,直通交换模式又有快速转发交换和碎片丢弃交换

总结说有 3 模式:

快速转发(通常也称直通交换模式,不提供检错纠错,适合小型交换机采用)

碎片丢失(又称无分段模式,提前过滤冲突碎片,提高宽带利用率)

存储转发(延时大,速度慢,可靠性高,可检错纠错,最为广泛应用)

堆叠交换机:2-10gbps 6-8 个堆叠数量 有达 16 个的 箱体模块化交换机:2-20 个

VLAN 技术特性: 工作在数据链路层

每个 VLAN 都是一个独立的逻辑网段,一个独立的广播域

VLAN 之间不能直接通信,必须通过第三层路由功能完成

VLAN 标识,vlan id 用 12 位 bit 表示,支持 4096 个 vlan ;1-1005 是标准范围,其 中 1-1000 是用于以太网

交换机之间实现 trunk 功能,必须遵守相同的 vlan 协议,如思科 isl

划分 vlan

(1) 基于端口划分(静态划分,最通用)

(2) 基于 mac 地址(动态的划分)

(3) 第三层协议类型或地址

交换机配置

duplex auto/full/half 配置端口通信方式

speed 10/100 speed auto 端口传输速率

VTP 实现 VLAN 的单一管理

Switch(config)#vtp domain todd 设置域名

Switch(config)#vtp password aaa

Switch(config)#vtp mode client /server/transparent

虚拟局域网 VLAN

查看VLAN 命令 Switch#show vlan

创建 VLAN Switch#config t Switch(config)#vlan 2

Switch(config-vlan)#exit

一个一个端口的分配

Switch(config)#Interface fastEthernet 0/1

 

 

Switch(config)#interface range fastEthernet 0/11 - 24

Switch(config-if-range)#switchport access vlan 2

建立,修改: vlan 1000 name vlan1000

删除:no vlan 1000

vlan interface f0/1

switchport access vlan 1000

Switch(config)#interface vlan 1

Switch(config-if)#ip address 192.168.0.100 255.255.255.0

Switch(config-if)#no sh

Switch(config-if)#exit

Switch(config)#ip default-gateway 192.168.0.1

Switch(config)#enable password aaa

Switch(config)#line vty 0 4

Switch(config)#line vty 0 15

Switch(config-line)#password aaa

Switch(config-line)#login

VLAN Trunk

Switch(config-if)#switchport mode trunk

Router(config)#interface gigabitEthernet 6/0

Router(config-if)#no sh

Router(config)#interface gigabitEthernet 6/0.1

Router(config-subif)#encapsulation dot1Q 1

Router(config-subif)#ip address 192.168.0.1 255.255.255.0

带路由模块的交换机实现 VLAN 间路由

两台交换机配置 trunk:

Conf t

Interface f0/0

Switchport mode trunk

Switchport trunk encapsulation dot1q/isl

Switchport trunk allowed vlan 1,4

Switchport trunk allowed vlan 1-4

Switchport trunk allowed except vlan 1-2

生成树(STP)

Spanning-tree vlan 2

No spanning-tree vlan 2 打开与关闭树

Spanning-tree vlan 2 root primary 设置主 root根网桥

Spanning-tree vlan 3 root secondary 设置备份 root 备份网桥

Spanning-tree vlan 3 priority 8192 设置优先级(0,4096,8192.。。。 到 61440)

配置可选功能:

Spanning-tree backbonefast (不是连接 本交换机的链路失效时) 30 秒

Spanning-tree uplinkfast (连接本交换机链路失效 1-5 分钟

Spanning-tree uplinkfast max-update-rate (0-32000)

Spanning-tree portfast default

Spanning-tree portfast bpdufilter default

重点提示

※生成树协议STP的主要功能是在保证网络中没有回路的前提下,允许在第二层链路中提供冗余路径,保证网络能够稳定、可靠地运行。STP的主要算法是生成树算法,该算法的核心是根网桥的选择。BPDU为STP的根网络确定乃至整个树状结构的生成提供必要的信息。

※交换机的动态转发交换模式主要包括:快速转发交换模式、碎片丢弃交换模式、 存储转发交换模式。前两种交换换模式的交换机在接收到数据帧后,仅将数据帧中的目的MAC地址拷贝到缓冲区内即进行转发;存储转发交换模式要求交换机将整个数据帧保存到缓冲区中,再进行转发处理。

交换机的配置

配置方式

1.使用Console端口配置

(1)将信号线的一端接在笔记本电脑的异步串行口(COM1或COM2)上,另一端接入交换机的Console接口,给交换机接上电源 。

(2)在Windows XP/2000中,【开始】-【所有程序】-【附件】-【通迅】-【超级终端】。

(3)点击【超级终端】后弹出“连接描述”窗口。在“名称(N):”栏下的框内键入新的连接名,例如“switch”,点击【确定】。

(4)弹出“连接到”窗口。在“连接使用(N):”一栏的下拉框中选择所连接上的端口。即由Console线所连接到笔记本电脑的异步传输口COM1或COM2,本次连接Console连接的是COM1口,所以选中“COM1”选项,点击【确定】。

(5)弹出“COM1属性”窗口,如图6-18所示。设置窗口中每一栏的端口参数。“每秒位数(B):”即传输速率设为9600;“数据位(D):”为8位;“奇偶校验(P):”选择“无”;“停止位(S):”为1位;“数据流控制(F):”选择“硬件”。设置完成后点击【确定】。

(6)在配置终端是按“回车”键,配置终端的屏幕上将会显示交换机的初始化信息,交换机初始化完成以后,将出现普通用户模式的提示符。

2.使用telnet命令配置 先做好以下几点工作:

交换机与作为模拟终端的计算机都与网络连接,且能通过网络进行通信。

该计算机有访问交换机的权限。

交换机已配置好设备管理地址(如IP地址、子网掩码等)和控制远程登录的密码 。

(1)在Windows XP/2000中,【开始】-【运行(R)...】进入“运行”窗口。

(2)设交换机的IP地址为222.159.61.182,“运行”窗口的框中输入命令“telnet 222. 159. 61. 182”。这时屏幕中将出来交换机的信息 。

3.使用浏览器配置 确认已经做好以下准备工作:

在用于配置的计算机中已安装TCP/IP协议,并且在用于配置的计算机和被管理的交换机上都已经配置好IP地址,它们可以通过网络进行通信。

用于配置的计算机中安装有支持Java的Web浏览器,如Internet Explorer 4.0及以上版本、Netscape 4.0及以上版本等。

在被管理的交换机上建立了拥有管理权限的用户帐户和密码。

被管理交换机支持HTTP服务,并且已经启用了该服务。

(1)把计算机连接在交换机的端口上,在计算机上运行Web浏览器。在浏览器的地址栏中键入被管理的交换机的IP地址,单击回车键连接交换机。

(2)弹出“连接到” 对话框。在“用户名(U):”框中输入管理权限的用户名,在“密码(P):”框中输入管理权限的密码,用户名与密码应该已经事先通过Console端口设置好。点击【确定】。

(3)在Web浏览器中显示交换机的管理界面。页面为与Cisco Catalyst 1900建立连接后,显示在Web浏览器中的配置界面。首先看到的是要求输入用户帐号和密码,这时您就输入在先前已设置好的交换机配置超级用户帐号和密码进入系统。

责任编辑:林琳 来源: 博客园
相关推荐

2010-01-18 16:51:14

交换机配置不当

2011-09-13 12:22:57

端口监听配置Cisco端口镜像配置

2010-01-14 10:43:18

交换机配置交换机种类

2023-04-13 10:12:43

PoE网络交换机

2010-01-04 13:31:13

Catalyst 19

2010-01-05 14:29:59

2010-01-05 10:14:39

交换机配置TRUNK

2011-03-08 10:58:38

VLANIP

2010-01-14 10:00:08

交换机VLAN应用

2013-12-11 13:30:20

交换机技术交换机配置

2011-03-09 14:00:21

trunkVLAN

2011-08-16 13:12:19

交换机配置

2010-03-12 16:57:38

2009-04-14 09:53:00

交换机分类

2010-01-12 14:57:10

华为交换机配置备份

2011-03-08 10:17:14

VLAN

2010-03-12 17:09:18

2010-03-17 12:46:57

交换机配置

2010-03-19 14:23:24

交换机TRUNK配置

2011-03-21 13:50:26

交换机
点赞
收藏

51CTO技术栈公众号