Cisco路由器及交换机口令集合

网络 路由交换
Cisco路由器及交换机口令复杂繁多,此文经过收集整理,希望大家能从中有所收益。

交换机口令设置:

switch>enable ;进入特权模式

switch#config terminal ;进入全局配置模式

switch(config)#hostname ;设置交换机主机名

switch(config)#enable secret xxx ;设置特权加密口令为xxx

switch(config)#enable password xxx ;设置特权非密口令为xxx

switch(config)#line console 0 ;进入控制口(Rs232)初始化

switch(config-line)#line vty 0 4 ;进入虚拟终端virtual tty

switch(config-line)#login ;允许登录

switch(config-line)password xx ;设置登录口令xx

switch#exit ;返回命令

交换机VLAN设置:

switch#vlan database ;进入VLAN设置

switch(vlan)#vlan 2 ;建VLAN 2

switch(vlan)#no vlan 2 ;删VLAN 2

switch(config)#int f0/1 ;进入端口1

switch(config-if)#switchport access vlan 2 ;当前端口1加入VLAN 2

switch(config-if)#switchport mode trunk ;设置为干线

switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许的VLAN

switch(config-if)#switchport trunk encap dot1q ;设置VLAN中继

switch(config)#vtp domain ;设置VTP域名

switch(config)#vtp password

switch(config)#vtp mode server

switch(config)#vtp mode client

交换机设置IP地址:

switch(config)#interface vlan 1 ;进入VLAN 1

switch(config-if)#ip address ;添加远程登录IP

switch(config)#ip default-gateway ;添加默认网关

switch#dir flash ;查看内存

交换机显示命令:

switch#write ;写入保存

switch#show vtp

switch#show run ;查看当前配置信息

switch#show vlan ;看VLAN

switch#show interface ;查看所有端口信息

switch#show int f0/0 ;显示端口0的信息

路由器显示命令:

router#show run ;显示接口

router#show interface ;显示接口

router#show ip route ;显示路由

touter#show cdp nei ;看邻居

router#reload ;重新启动

设置口令:

router>enable ;进入特权模式

router#config terminal ;进入全局配置模式

router(config)#hostname ;设置交换机的主机名

router(config)#enable secret xxx ;设置特权加密口令为xxx

router(config)#enable password xxx ;设置特权非密口令为xxx

router(config)#line console 0 ;进入控制台(Rs232)初始化

router(config-line)#line vty 0 4 ;进入虚拟终端virtual tty

router(config-line)#login ;允许登录

router(config-line)password xx ;设置登录口令xx

router(config)#(Ctrl+z) ;返回特权模式

switch#exit ;返回命令

配置IP地址:

router(config)#int s0/0 ;进行串serail接口

router(config-if)#no shutdown ;启动接口

router(config-if)#clock rate 6400 ;设置时钟

router(config-if)#ip address 10.1.1.1 255.255.0.0 ;设置IP地址和子网掩码

router(config-if)#ip add 10.1.1.2 255.255.0.0 second

router(config-if)#int f0/0.1 ;进入子接口

router(config-subif.1)#ip address

router(config-subif.1)#encapsulation dot1q

router(config)#config-register 0x2142 ;跳过配置文件

router(config)#config-register 0x2102 ;正常使用配置文件

router#reload ;重新引导

复制操作:

router#copy running-config starup-config ;存配置

router#copy running-config tftp ;上载

router#copy startup-config tftp

router#copy tftp flash: ;特权模式下升级IOS

router#copy tftp startup-config ;下载配置文件到nvram

ROM状态:

Ctrl+Break ;进入ROM监控状态

rommon>confreg 0x2142 ;跳过配置,26 36 45xx

rommon>confreg 0x2102 ;使用配置,恢复工作状态

rommon>reset ;重新引导,等效于重新开机

rommon>copy xmodem: flash ;从console升级IOS

IOS:

rommon>IP_ADDRESS=10.65.1.2

rommon>IP_SUNNET_MASK=255.255.0.0

rommon>TFTP_SERVER=10.65.1.1

rommon>TFTP_FILE=c2600.bin

rommon>tftpdnld

rommon>dir flash:

rommon>boot

#p#

静态路由:

ip toute

例:

router(config)#ip toute 10.1.0.0 255.255.0.0 10.2.1.1

router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2

动态路由:

router(config)#ip routing ;启动路由

router(config)#router rip ;启动RIP路由协议

router(config-router)#network ;配置范围,有的支持all

router(config-router)#negihbor ;点对点

帧中继命令:

router(config)#frame-relay switching ;使能帧中继交换

router(config-s0)#encapsulation frame-relay ;使能帧中继

router(config-s0)#frame-relay intf-type DCE ;DCE端(需要配虚电路)

touter(config-s0)#farme-relay local-dlci 20 ;配置虚电路号

基本访问控制列表:

router(config)#access-list permit|deny

router(config)#interface ;default:deny any

router(config-if)#ip access-group in|out ;default:out

例:

RB(config)#access-list 4 permit 10.8.1.1

RB(config)#access-list 4 deny 10.8.1.0 0.0.0.255

RB(config)#access-list 4 permit 10.8.0.0 0.0.255.255

RB(config)#access-list 4 deny 10.0.0.0 0.255.255.255

RB(config)#access-list 4 permit any

RB(config)#int f0/0

RB(config-if)#ip access-group 4 in

扩展访问列表:

access-list permit|deny icmp [port]

例1:

router(config)#access-list 101 deny icmp any 10.64.0.2 0.0.0.0 echo

router(config)#access-list 101 permit ip any any

router(config)#int s0/0

router(config-if)#ip access-group 101 in

例2:

router(config)#access-list 102 deny tcp any 10.65.0.2 0.0.0.0 eq 80

router(config)#access-list 102 permit ip any any

router(config)#interface s0/1

router(config-if)#ip access-group 102 out

router(config)#no access-list 102

router(config-if)#no ip access-group 101 in

在路由器上设置SNMP Community Strings:

router(config)#snmp-server community read-community-string ro

router(config)#snmp-server community write-community-string rw

在交换机上设置SNMP Community Strings:

switch(config)#snmp-server community read-community-strings ro

switch(config)#snmp-server community write-community-strings rw

在路由器上配置日志信息(Syslog Message logging):

router(config)#logging on

router(config)#logging server-ip-address

router(config)#logging trap serverity-level

路由器恢复出厂设置

erase start-config

或write erase

或erase NVROM

责任编辑:张存 来源: 思科官方微博
相关推荐

2011-08-16 13:55:03

交换机Cisco

2011-03-31 09:09:00

2009-11-27 09:44:21

Cisco路由器交换机

2011-07-21 13:46:09

Cisco ACE

2010-01-12 09:38:24

华为路由器交换机

2010-01-11 15:31:54

Cisco交换机

2012-12-10 10:01:07

Cisco路由器交换机

2009-11-26 09:56:39

Cisco路由器配置命交换机配置命令

2009-12-16 13:33:43

Cisco路由器口令恢

2017-06-01 14:33:04

交换机路由器网络设备

2011-03-24 14:05:14

Nagios监控

2010-02-01 09:04:47

2009-12-03 11:43:30

路由器交换机区别

2009-12-03 13:24:46

路由器交换机区别

2009-12-02 10:25:18

2013-01-28 10:13:27

交换机路由器路由功能

2022-09-22 17:00:46

路由器

2011-08-08 10:47:07

路由器交换机

2009-12-23 16:01:38

路由器交换机

2022-09-22 19:19:52

网络硬件路由器交换机
点赞
收藏

51CTO技术栈公众号