中小企业网络管理:路由器的启动与管理

网络 路由交换
今天我们继续中小企业网络管理的第二篇,路由器的启动过程与各种管理方式。内容就涉及到二个方面,一个是路由器的启动,当然这里包括路由器的启动过程,路由器的组件,以及IOS相关的操作,二是介绍对Cisco设备进行管理的几种方式。

今天我们继续中小企业网络管理的第二篇,路由器的启动过程与各种管理方式。内容就涉及到二个方面,一个是路由器的启动,当然这里包括路由器的启动过程,路由器的组件,以及IOS相关的操作,二是介绍对Cisco设备进行管理的几种方式。

我们先来看一下路由器的启动过程,其实路由器和计算机一样,也有一个加电启动的过程,如果想了解路由器的启动过程就必须要先了解路由的内部组件,我们来看一下

路由器内部组件

一般来说路由器就由这么几部分组成,我们来介绍一下:

[[58057]] 

Flash如同PC机上的BIOS(基本输入输出系统),其中存放的是Cisco路由器的IOS,对它的维护主要就是对IOS文件的备份和恢复。在路由器的enable状态下用“dir”命令,就可以查看到Flash上存储的IOS文件名及其大小。Flash是可编程的存储器,因此可以对Flash进行编程而升级IOS,也能用“erase flash”删除Flash中的IOS,所以这一命令的使用必须非常谨慎。我们可以通过备份一个IOS映像文件在计算机上,以在需要时修复IOS。用作备份的计算机要作为TFTP服务器,即它需要运行TFTP Server的软件。

NVRAM我个人认为翻译成非易失性RAM比较合适。如同PC机上的CMOS,其中存放的是路由器的配置文件。NVRAM的内容可以用“erase memory”或“write erase”将配置参数删除到出厂设置状态,所以相对于路由器丢失了IOS,删除NOVRAM的后果不是很严重,恢复起来也容易一些。在路由器正常启动后,它会将NVRAM的内容拷贝到内存一份,我们对路由器的设置实际上就是修改内存中的参数。所以内存和NVRAM中的内容是可以不一样的,直到使用“write memory”、“copy running-config startup-config”将内存设置保存到NVRAM中,或用“reload”、“copy startup-config running-config”、重启路由器等办法将NVRAM的内容重新调入内存,才能实现NVRAM与内存之间的同步。用“show configuration”命令可查看NVRAM中的设置,用“show running-config”、“write terminal”命令则可以查看当前运行的设置(在内存中)。

ROM 在Cisco路由器中的功能与计算机中的ROM相似,主要用于系统初始化等功能

 

ROM中实现的功能主要包含:

POST的注册

引导顺序的微调(可以实现密码恢复等功能)

Mini IOS的启动

 

ROM模式的启动

在IOS启动后可以通过show version 命令查看ROM中的信息

Bootstarp是位于ROM微码中的程序,用于执行程序。负责找到每个IOS的位置然后加载该文件。默认情况下,所有的Cisco路由器都从flash中加载IOS软件。

POST 也是存放于ROM中微码中的程序,用来检查硬件基本配置是否正常,然后决定哪些接口可用。

ROM Momitor:存储在ROM的微码中,作用是测试和排疑等。

Mini IOS :是一个简化的IOS

RAM 也就是咱们所说的内存,是可读可写的存储器,但它存储的内容在系统重启或关机后将被清除。和计算机中的RAM一样,Cisco路由器中的RAM也是运行期间暂时存放操作系统和数据的存储器,让路由器能迅速访问这些信息。RAM的存取速度优于前面所提到的3种内存的存取速度。)

当然这里应该还有一个必须的部件就是CPU,至于它的作用,就明白人不用细说!

另外还有一个比较重要的东西就是IOS

Cisco IOS Software Features

IOS 是路由器和交换机的操作系统的简称,全名是Internetwork Operation System,也就是说IOS就相当于PC的操作系统。

只是交换机有默认设置,而路由器没有默认设置,所以不论你买什么型号的交换机都可以不用配置直接使用,但不论你什么型号怕路由器,那怕是家庭使用的宽带路由器也必须要经过设置才可以作用。

这个IOS分为两类,主要发布版本(MR)和前期研发发布版本(EDR)。

主要版本(MR)是IOS技术部门负责管理和发布的IOS版本,这些版本继承于之前的早期研发版本,具有更可靠的特性、平台支持、功能和技术。因此IOS MR具有更好的可靠性和性能,并县域,MR不在接受对新的特性和平台的支持,每个升级维护的版本的改变只是对已知软件错误的修正。

研发版本(ED)是Cisco对为了满足对新技术和新平台的技术而开发的IOS版本。也就是说每个更新的ED版本的发布除了修正已知的软件错误之外,都会不断带给客户更多的新特性。并且,每个ED版本发布1至2年后,就会晋级成为下一个IOS的主要版本。

Cisco IOS的命名规范

Cisco IOS二进制文件的命名由3部分组成,其中第一部分表示的是平台也就是适合的型号,第二部分是特性,第三部分是运行时内存和压缩格式。

 

如C7200-ajs40-mz

C7200 表示的是 Cisco 7200系统路由器

Ajs a 表示的是高级,j 表示的是企业特性 s 表示的是附加特性

Mz m 表示IOS在运行时所处的内存 z 表示的是zip压缩.#p#

其中运行的位置包括以下几种:

F 运行在 flash

m 运行在RAM

R 运行在 ROM

L image will be relocated at run time

压缩标识符:

Z zip 压缩

X mzip 压缩

W “Stac” 压缩

那么,大家知道了路由器的组成部件以及IOS的作用,我们就可以来分析一下路由器的启动顺序,如图所示:

 

1. 在ROM中检查启动注册值(也叫做寄存器值)。这个值相当重要!后面介绍

2. 将NVROM中的Startup-configuration 文件copy到内存里

3. 默认情况下将flash中的第一个IOS文件加载到内存中。

4. 如果没有在flash中找到IOS文件,则在网络中尝试寻找TFTP Server.

5. 如果找不到 TFTP Server,则使用RXBOOT模式,也就是加载ROM中的Mini IOS.

6. 如果不能加载 Mini IOS,则使用ROMMON启动。

到这里我相信大家都能看的明白,下面咱们开始进行这一节的一个重点,详细分析一下路由器的启动流程图:如果大家把这个图看明白了,那么路由器的启动就没有问题了!

 

这个启动的过程还是有点小复杂的,好,我开始给大家做一个分析:

首先我们开始启动路由器,第一步到了boot field=0 如果成立就启动Rom monitor模式,如果不成立也就是说不等于0的话,再判断field=1是否成立,如果成立就开始从RXboot模式启动,也就是从mini IOS方式启动。那如果不成立的话,则去检查NVRAM中的start-up config中有没有boot system commands 命令,如果有,就按照这个命令去执行(do what they say)它说从哪儿启动就从哪儿启动,那如果没有这个命令,就检查flash中没有一个合法的IOS文件,如果有,就使用这个IOS从继续向下走,加载这个IOS。那如果flash中没有IOS怎么办呢?就执行 attempt to get ios from network,也就是从网络上寻找IOS(TFTP服务器),如果成功,就从网络上使用这个文件来加载IOS,那如果运气比较差,从网络上没有找到IOS,那么就查看寄存器中第13位的值是否=1,如果成立,就会判断是否已经有5次失败了,如果没有则再从网络上查找此文件,也就是说找TFTP服务器,共寻找了五次如果都不成功最后才失败,那么这个时候就只能从mini IOS启动了,没有办法了!那如果这个13位如果不等于1,等于0就比较危险了,就进入了一个死循环。所以说这个第13位一般都是1!

位数 0 1 2 3 4 5 6 7 8 9 A B C D E F

值      0 0 0 0                                1

现在我们已经分析到了 load IOS,然后再判断第6位是否等于1,如果成立就直接进行DIALOG开始启动路由器,也就是说NVRAM中没有配置文件,那如果不等于1就说明以前有配置文件再判断这个文件是否合法,如果合法 然后就从NVRAM中取出此配置文件,启动成功,如果没有又进行DIALOG方式开始配置。至此启动全部结束!

那么这个第6位设置为1适合于路由器密码丢失的场合!因为密码都是存放在配置文件中,配置文件又是在NVROM中的,所以跳过即合!但不要忘记,设置正确的密码后,保存到配置文件,然后再将此值改为1。

下面咱们就来看一下IOS相关的操作,我们知道设备的IOS是存放在FLASH中的,如图所示

[[58058]] 

Flash中存储着IOS文件,路由器启动的时候会自动在flash中寻找正确的IOS文件并加载到内存中运行,我们也可以通过show flash命令查看flash中的文件,如图所示:

 

我们从图中可以看出IOS文件名,flash所用的空间,剩余空间以及总空间。

当然也可以从NVRAM中查看配置文件的信息,配置文件是存放在NVRAM中的,我们从上面的启动过程就已经看到了。启动的时候会查看NVRAM中有没有可用的配置文件,如果有就直接调入RAM,如果没有再启动DIALOG,如图所示:

 

我们也可以通过命令来查看NVRAM中的配置文件,也就是保存在NVRANK中的配置文件 startup-config或者是查看RAM中的配置文件,也就是正在运行的配置文件。我们来看一下
 

 

大家可以看到我当前有正在runing的配置文件,但是NVRAM中是没有配置文件的,所以我们可以把我们现在runing 的配置文件备份到NVRAM中。如图所示:
 

 

 

如果我们当前的配置文件错了,我们也可以直接从NVRAM中还原我们的配置,如图所示:

 

[[58059]] 

 

我在此将路由器名称设置为dufei,然后从备份中进行还原,成功后显示为ITET,当然除了RAM和NVRAM之间进行配置文件的复制之外还可以实现RAM,NVRAM和TFTP服务器之间进行配置文件的复制,如图所示:
 

 

如我们希望将当前的配置文件保存到 TFTP服务器,可以作用命令 copy running-config tftp

 

这里会问你TFTP服务器的地址,然后再让你输入配置文件名.#p#

那如果是将从TFTP服务器还原,可以使用copy tft run

 

实现NVRAM和TFTP之间复制也同理:

 

我们也可以删除NVRAM中的配置文件,如图所示:

 

我们也可以对IOS进行备份和还原,我们可以通过TFTP服务器来备份IOS,也就是将IOS备份到TFTP服务器上。如果大家刚才配置文件的备份和还原会了,那么IOS的备份也还原大家也就会了,因为语法一模一样!

当然也有需要注意的地方

1 设备和服务器的网络是通的,这是前提

2 一定保证双方的磁盘空间是足够的,否则会失败

3 创建文件,一定要注意是文件全名。

我们来看一下怎么将IOS进行备份,以供还原时使用,首先我们先显示一下flash中的信息,也就是使用 show flast

 

 

这里可以将文件名复制下来,以方便使用。但一定要注意一个剩余空间。

然后执行命令: copy flash tftp进行IOS的备份,

 

还原的时候也一样:使用命令 copy tftp flash

到现在为止,咱们已经很详细的把路由器的启动过程IOS以及配置文件的备份和还原介绍完了,下面咱们来看一下如何管理Cisco设备:

我们一般对Cisco设备进行管理有以下方式:

 

 

大家通过这个图可以看到以下方式:

Console port 用于对新设备的配置

Aux port 用于远程拔呈对设备控制

Telnet (Virtual Terminal ) 用于对已经配置好的设备进行远程管理

TFTP 用于备份或升级IOS及配置文件

Web 或NAS 可以利用一些网管软件对设备进行综合管理

下面我们逐个介绍:

Hyper Terminal:

第一次配置路由器的时候必须使用Console接口进行配置。第一次使用交换机的时候如果不进行VLAN等操作,可以不进行配置。

使用方法如下:将控制线的一端插在路由器的console口上,另一头插在计算机的串中上,然后点开始—附件--- 通讯--- 超级终端

 

 

 

[[58060]] 

此处采用默认设置即可!

Aux

当与远端路由器连接的链路失效,可以使用Modem通过PSTN网络拨号控制远程网络设备。

Vty

当与远端路由器连接的链路可用时,可以使用TCP协议的Telnet服务控制远程网络设备。

TFTP/FTP

将网络设备的配置文件保存在TFTP或者FTP服务器上,可以随时对网络设备的配置进行恢复。

SNMP

当网络环境比较复杂或者网络设备距离较远的时候,可以使用SNMP服务也就是咱们所说的网管软件进行管理。

因为在正常的工作中,telnet方式使用的是比较多的,在下面将给出我们的第一个实验:当然这两个实验比较简单,咱们就从浅入深,

Lab1:Telnet 管理交换机

实验目的:通过telnet 方式远程访问cisco 交换机

 

 

实验设备:两台cisco 系统的交换机,一条以太网交叉线

注意:在大型网络中,Telnet的应用是非常大的,即方便我们对网络的排错和配置,又减少了人工在换线过程的消耗,大大的提高了工作效率。

图例:

具体配置:

Switch1:

Switch>enable 从全局模式进入特权模式

Switch#configure terminal 进入配置模式

Switch(config)#hostname SWA 为设备起名

SWA(config)#interface vlan 1

SWA(config-if)#ip address 192.168.0.1 255.255.255.0 为交换机配置IP

SWA(config-if)#no shutdown

SWA(config-if)#exit 退出配置模式

SWA(config)#username admin password admin 配置用户名口令

SWA(config)#line vty 0 4

SWA(config-line)#login local 启动本地验证

Switch2:

Switch>enable

Switch#config terminal

Switch(config)#hostname SWB

SWB(config)#interface vlan 1

SWB(config-if)#no shutdown

SWB(config-if)#ip address 192.168.0.2 255.255.255.0

SWB(config-if)#exit

SWB(config)#username dufei password dufei

SWB(config)#line vty 0 4

SWB(config-line)#login local

验证:配置完成后,可以在特权模式下用show running-configuration 查看配置信息。此处略。

在检查配置没有问题后,在特权模式下可以使用ping检测两台交换的网络连通性。

 

至此,实验成功!

Lab2: Telnet管理路由器实验

实验目的:通过Telnet远程访问Cisco路由器

[[58061]] 

实验设备:两台Cisco系统路由器,一以太网交叉线

图例:

Router0:

Router>enable

Router#configure terminal

Router(config)#hostname RA

RA(config)#interface fastEthernet 0/0

RA(config-if)#ip address 192.168.0.1 255.255.255.0

RA(config-if)#no shutdown

RA(config-if)#exit

RA(config)#username admin password admin

RA(config)#line vty 0 4

RA(config-line)#login local

Router1:

Router>enable

Router#config terminal

Router(config)#interface fastEthernet 0/0

Router(config-if)#ip address 192.168.0.2 255.255.255.0

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#exit#p#

测试网络的连通性

Router#ping 192.168.0.1 出现下图所示:

 

然后再Router1上远程Telnet到Router0上

 

实验成功!!

而且大家在使用Telnet的时候会使用一个小技巧,就是Ctrl+shift+6:x 可以快速的回到本地设备上,如果希望再次连接到远程计算机,则可以使用的方法

 

可以使用命令disconnect 命令关闭一个从本地发起的telnet会话,

可以使用clear line 命令关闭一个从对端发起的telet会话

以上内容就较为详细的介绍了路由器的启动过程及各种管理方法。好了,今天就到这儿了!

 

 

【编辑推荐】

  1. “林书豪”式无线管理路由器——飞鱼星VE984W
  2. 华硕无线路由器RT-N10+引领无线数字生活
  3. 你家的路由器落伍了
  4. 飞鱼星VR470G全千兆路由器 网吧进入飞时代
  5. 企业路由器明星 飞鱼星VE982W获“金e奖”
责任编辑:Writer 来源: it168网站
相关推荐

2009-02-24 14:03:06

2012-02-17 09:26:34

2012-02-23 15:16:53

IP路由数据包路由协议

2013-06-04 13:48:04

OSPF路由协议OSPF协议OSPF

2009-08-11 14:24:24

中小企业网管网络管理应用

2009-12-01 10:56:10

2013-03-01 10:48:28

2012-02-22 10:38:42

CDP

2012-02-21 13:07:46

网络管理设备

2014-04-30 11:17:53

2012-11-22 10:15:35

中小企业路由器

2009-11-10 16:52:32

2009-11-30 16:51:37

2009-04-22 09:44:00

2016-06-25 16:53:20

WOT2016网络安全

2012-03-02 10:45:09

广域网ISDN网络协议

2009-11-10 11:29:04

2009-12-01 13:10:40

2009-11-09 16:59:56

2009-11-17 17:07:56

中小企业路由器
点赞
收藏

51CTO技术栈公众号