全析vpdn pppoe配置

网络 网络管理
这里我们主要介绍的是vpdn pppoe配置的内容,首先我们会对其概念做一个简单的介绍,然后再来分析一下案例。

在很多组网过程中,我们需要结合相应的业务来设定有关的协议内容。那么今天主要介绍的就是vpdn pppoe配置的内容。首先让我们看看VPDN的概念。VPDN是基于拨号接入(PSTN、ISDN)的虚拟专用拨号网业务,可用于跨地域集团企业内部网、专业信息服务提供商专用网、金融大众业务网、银行存取业务网等业务。

VPDN采用专用的网络安全和通信协议,可以使企业在公共网络上建立相对安全的虚拟专网。VPN用户可以经过公共网络,通过虚拟的安全通道和用户内部的用户网络进行连接,而公共网络上的用户则无法穿过虚拟通道访问用户网络内部的资源。

VPDN技术适用于以下范围:

地点分散,在各地有分支机构,移动人员特别多的用户,例如企业用户、远程教育用户。

人员分散,需通过长途电信甚至国际长途手段联系的用户。

对线路的保密和可用性有一定要求的用户。

此外,通过VPDN技术,可实现对特定站点的封闭,可向小ISP和大集团用户提供一次、多次端口批发业务。

VPDN网络结构由局端(或称为中心端)和客户系统组成。VPDN客户系统包括两部分:企业端与远端。通常企业端是企业的内部局域网,以专线方式接入UNINET;远端是拨号客户,以拨号方式访问企业内部局域网。

vpdn pppoe配置案例分析:

此案例为XX电信adsl PPPoE接入,需要使用一个普通adsl modem和一台cisco 2600路由器(双以太口),IOS 12.2(15)T,能够实现局域网共享上网。

此案例配置共分7步:

vpdn pppoe配置第一步:配置vpdn

vpdn enable(启用路由器的虚拟专用拨号网络——vpnd)

vpdn-group office(建立一个vpdn组,)

request-dialin(初始化一个vpnd tunnel,建立一个请求拨入的vpdn子组,)

protocol pppoe(vpdn子组使用pppoe建立会话隧道)

vpdn pppoe配置第二步: 配置路由器连接adsl modem的接口

interface Ethernet1

no ip address

pppoe enable允许以太接口运行pppoe

pppoe-client dial-pool-number 1将以太接口的pppoe拨号客户端加入拨号池1

vpdn pppoe配置第三步:配置逻辑拨号接口:

interface Dialer1

ip address negotiated从adsl服务商动态协商得到ip地址

ip nat outside为该接口启用NAT

encapsulation ppp为该接口封装ppp协议

dialer pool 1该接口使用1号拨号池进行拨号

dialer-group 1该命令对于pppoe是意义不大的

ppp authentication pap callin启用ppp pap验证

ppp pap sent-username xxxxxxx password 0 yyyyyyy使用已经申请的用户名和口令

vpdn pppoe配置第四步:配置内部网络接口

interface Ethernet0(内部网络接口)

ip address 10.1.1.1 255.255.255.0

ip nat inside为该接口启用NAT

vpdn pppoe配置第五步:配置路由器为内部网络主机提供dhcp服务

ip dhcp excluded-address 10.1.1.1

ip dhcp pool ABC

import all(导入dns和wins server)

network 10.1.1.0 255.255.255.0

default-router 10.1.1.1

vpdn pppoe配置第六步:配置NAT:

access-list 1 permit 10.1.1.0 0.0.0.255

ip nat inside source list 1 interface Dialer1 overload

vpdn pppoe配置第七步:配置缺省路由

ip route 0.0.0.0 0.0.0.0 Dialer1

责任编辑:佟健 来源: IT实验室
相关推荐

2010-09-29 14:04:25

RHCE DHCP配置

2010-09-02 15:50:01

PPPoE协议

2010-09-16 15:50:55

PPPoE配置

2010-09-16 13:16:20

CISCO PPPoE

2010-09-14 15:10:30

PPPoE配置宽带连接

2010-07-21 16:08:57

telnet命令

2010-09-06 09:18:08

PPP Options

2010-09-07 15:27:01

2010-09-09 17:34:19

PPPoE Serve

2010-09-16 13:03:02

PPPoE协议配置

2010-09-16 09:52:46

2010-09-07 11:58:12

R621 PPPoE配

2010-09-14 15:30:27

2010-09-16 16:06:35

PPPoE配置

2010-09-07 13:57:09

PPPoE Serve

2009-09-24 12:50:23

Hibernate F

2010-02-22 11:02:55

Python功能

2010-09-07 14:30:20

Linux PPPoE

2010-09-06 17:35:03

PPPOE配置

2010-03-01 13:19:21

Python线程内容
点赞
收藏

51CTO技术栈公众号