动手演练之DHCP实验

网络 网络管理
文章中,我们针对DHCP实验的内容进行分析和讲解,通过实验内容,我们可以为大家讲解一下相关操作。

随着我们对DHCP协议的深入了解,我们不妨动手做一下DHCP实验,来帮助我们了解DHCP的有关操作。这里我们就来讲解三个DHCP实验。近日,有朋友问我一些DHCP实验的一些问题。随便就再把DHCP的实验重新做了一次,与大家分离一下:

DHCP实验一:无DHCP代理

拓扑如下:

Router0配置如下:

!interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
!
ip dhcp excluded-address 192.168.0.1
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool bapilong
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
dns-server 10.10.10.10

PC机可获取到IP地址,如图:

以上实验使用思科TP模拟器

DHCP实验二:使用DHCP中继代理

拓扑图如下:

Router1配置如下:


ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 20.20.20.1
!
ip dhcp pool work1
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   dns-server 100.100.100.100
!
ip dhcp pool work2
   network 20.20.20.0 255.255.255.0
   default-router 20.20.20.1
   dns-server 100.100.100.100
!
interface Ethernet1/0
ip address 23.1.1.2 255.255.255.0
!
ip route 10.10.10.0 255.255.255.0 23.1.1.1
ip route 20.20.20.0 255.255.255.0 23.1.1.1

Router2配置如下:

interface Ethernet1/0
ip address 10.10.10.1 255.255.255.0
ip helper-address 23.1.1.2
!
interface Ethernet1/1
ip address 23.1.1.1 255.255.255.0
!
interface Ethernet1/3
ip address 20.20.20.1 255.255.255.0
ip helper-address 23.1.1.2

DHCP实验结果如下:

PC2:

R1#Interface FastEthernet0/1 assigned DHCP address 10.10.10.2, mask 255.255.255.0
R4#show ip int br

Interface                  IP-Address         OK?   Method             Status                   Protocol
FastEthernet0/0       unassigned      YES      unset    administratively down        down   
FastEthernet0/1       10.10.10.2       YES       DHCP             up                             up

PC3:

R4#Interface FastEthernet0/1 assigned DHCP address 20.20.20.2, mask 255.255.255.0

Interface                  IP-Address      OK?      Method              Status                   Protocol
FastEthernet0/0      unassigned      YES        unset     administratively down      down   
FastEthernet0/1      20.20.20.2       YES         DHCP                 up                        up  

以上使用工大DY,CCNA路由版做为实验,用思科TP做这个实验时总是无法获取IP地址,故使用DY,其中的PC2为R3路由器,PC3为R4路由器,该两台路由器模拟成PC机,具体配置我就不帖出来了。

DHCP实验三:使用三层交换机

网络拓扑如下:

三层交换机配置如下:

  1. !  
  2. interface FastEthernet0/1  
  3. switchport access vlan 20  
  4. !  
  5. interface FastEthernet0/2  
  6. switchport access vlan 30  
  7. !  
  8. interface Vlan20  
  9. ip address 20.20.20.1 255.255.255.0  
  10. !  
  11. interface Vlan30  
  12. ip address 30.30.30.1 255.255.255.0  
  13. !  
  14. ip dhcp pool work1  
  15. network 20.20.20.0 255.255.255.0  
  16. default-router 20.20.20.1  
  17. dns-server 100.100.100.100  
  18. ip dhcp pool work2  
  19. network 30.30.30.0 255.255.255.0  
  20. default-router 30.30.30.1  
  21. dns-server 100.100.100.100 

DHCP实验结果如下:

PC4:

PC5配置如下:

以上使用思科TP做为实验工具。

责任编辑:佟健 来源: 网络整理
相关推荐

2010-09-01 10:27:43

vSphere服务器虚拟化VMware

2020-05-20 13:53:41

HTTP环境安装

2010-09-27 11:12:33

DHCP IP分配

2010-09-01 10:19:43

配置DHCP

2014-11-27 10:52:17

vlan路由

2009-12-14 13:18:34

Hyper-V虚拟机

2009-12-21 09:05:22

2011-03-02 11:15:21

WindowsPhon动手实验室

2011-03-02 11:21:31

WindowsPhon动手实验室

2010-08-31 11:37:26

vSphere服务器虚拟化VMwar

2010-09-01 10:37:04

vSphere服务器虚拟化VMware

2010-08-31 11:30:26

vSphere服务器虚拟化VMware

2010-09-03 12:19:18

DHCP服务器dhcp配置

2012-04-10 11:26:53

DNS服务

2010-09-01 11:31:52

vSphere服务器虚拟化VMware

2010-09-01 10:24:53

vSphere服务器虚拟化VMware

2010-08-30 16:14:26

DHCP实验

2010-08-30 17:13:01

DHCP中继代理

2013-08-27 15:00:41

华为云计算大会HCC2013

2010-06-28 10:11:00

桌面虚拟化虚拟化MED-V
点赞
收藏

51CTO技术栈公众号