Cisco IOS防火墙的安全配置方案

网络 路由交换
网络安全是一个系统的概念,有效的安全策略或方案的制定,是网络信息安全的首要目标,本文给大家详细的介绍了对于CISCO的防火墙的安全配置方案。

本文主要给大家介绍了对于CISCO路由器IOS的防火墙安全配置,并且给大家讲述了NAT转化功能的几点说明,相信大家看过此文能对CISCO路由器IOS有一定认识。

网络安全技术主要有,认证授权、数据加密、访问控制、安全审计等。而提供安全网关服务的类型有:地址转换、包过滤、应用代理、访问控制和D oS防御。本文主要介绍地址转换和访问控制两种安全网关服务,利用cisco路由器对ISDN拨号上网做安全规则设置。试验环境是一台有fir ewall版本IOS的cisco2621路由器、一台交换机组成的局域网利用ISDN拨号上网。

我们知道,Internet 技术是基于IP 协议 的技术,所有的信息通信都是通过IP包来实现的,每一个设备需要进行通信都必须有一个唯一的IP地址。因此,当一个网络需要接入Inte rnet的时候,需要在Internet上进行通信的设备就必须有一个在全球Internet网络上唯一的地址。当一个网络需要接入Internet上使用时,网络中的每一台设备都有一个I nternet地址,这在实行各种Internet应用上当然是最理想不过的。但是,这样也导致每一个设备都暴露在网络上,任何人都可以对这些设备攻击,同时由于I nternet目前采用的IPV4协议在网络发展到现在,所剩下的可用的IP地址已经不多了,网络中的每一台设备都需要一个IP地址,这几乎是不可能的事情。

采用端口地址转换,管理员只需要设定一个可以用作端口地址转换的公有Internet 地址,用户的访问将会映射到IP池中IP的一个端口上去,这使每个合法Internet IP可以映射六万多台内部网主机。从而隐藏内部网路地址信息,使外界无法直接访问内部网络设备。

Cisco路由器提供了几种NAT转换的功能:

1、内部地址与出口地址的一一对应
缺点:在出口地址资源稀少的情况下只能使较少主机连到internet 。

2、内部地址分享出口地址
路由器利用出口地址和端口号以及外部主机地址和端口号作为接口。其中内部地址的端口号为随机产生的大于1024的号码,而外部主机端口号为公认的标准端口号。这样可以用同一个出口地址来分配不同的端口号连接任意数量的内部主机到外网。

具体配置:由于实验用的是ISDN拨号上网,在internet上只能随机获得出口地址,所以NAT转换的地址池设置为BRI口上拨号所获得的地址。
interface FastEthernet0/0
ip address 172.16.18.200 255.255.255.0
ip nat inside the interface connected to inside world
!
interface BRI0/0
ip address negotiated
ip nat outside the interface connected to outside network
encapsulation ppp
no ip split-horizon
dialer string 163
dialer load-threshold 150 inbound
dialer-group 1
isdn switch-type basic-net3
ip nat inside source list 1 interface BRI0/0 overload
access-list 1 permit 172.16.18.0 0.0.0.255

3、内部地址和外部地址出现交叠
当内部和外部用同一个网络段地址时,在地址没有重复的情况下,可以同时对内外接口进行NAT转换使之可以正常通讯。

4、用一个出口地址映射内部多台主机
应用于internet上的大型网站有多台主机对应同一个系统的同一个出口地址。
可以用sh ip nat translation 和debug ip nat 命令来检查NAT的状态。

 

责任编辑:chenqingxiang 来源: ZDnet
相关推荐

2010-08-05 14:22:35

2010-08-03 09:32:32

2010-08-10 10:05:29

思科路由器配置防火墙

2009-12-01 17:13:35

2010-09-10 14:25:30

Cisco PIX防火

2010-09-25 16:34:30

CISCO ASA

2011-09-29 10:38:46

IPv6防火墙

2010-09-14 09:44:06

2010-08-03 09:39:45

路由器

2009-07-09 23:01:02

Cisco启动密钥

2010-09-14 10:30:55

Cisco PIX防火

2010-07-12 11:33:52

2010-09-25 16:46:28

2009-09-25 11:25:39

2022-09-20 16:38:08

数据安全数据泄露安全

2009-12-23 16:21:21

2010-09-25 17:17:19

2009-02-22 09:30:24

2019-07-18 11:26:13

防火墙网络安全软件

2011-03-15 15:47:15

Iptables防火墙
点赞
收藏

51CTO技术栈公众号