路由技巧之cisco路由器实现ADSL接入

网络 路由交换
本文具体的介绍了配置的步骤,在ADSL接入时,我们要进行哪些操作呢?具体的步骤有哪些呢?我们在配置时应该怎样去操作呢?下面文章将给出答案。

本文主要面向CISCO路由器主要给大家讲述了如何实现ADSL接入,并且给出了具体的操作步骤和配置命令,希望此文会对大家有所帮助。

说明:此案例为电信adsl PPPoE接入,需要使用一个普通adsl modem和一台cisco 2500(1841)路由器(双以太口),IOS 12.2(15)T,能够实现局域网共享上网.

此案例配置共分7步:

第一步:配置vpdn

router(config)#vpdn enable(启用路由器的虚拟专用拨号网络-vpnd)

router(config)#vpdn-group office (建立一个vpdn 组 office)

router(config-vpdn)#request-dialin(初始化一个vpnd tunnel,建立一个请求拨入的vpdn子组,)

router(config-vpdn-req-in)#protocol pppoe (vpdn子组使用pppoe建立会话隧道)

第二步: 配置CISCO路由器连接adsl modem的接口

router(config)#interface fastEthernet 0/1

router(config-if)#no ip address

router(config-if)#pppoe enable 允许以太接口运行pppoe

router(config-if)#pppoe-client dial-pool-number1将以太接口的pppoe拨号客户端加入拨号池1

第三步:配置逻辑拨号接口:

router(config)#interface dialer1 (配置逻辑拨号接口)

router(config-if)#ip address negotiated (从adsl服务商动态协商得到ip地址)

router(config-if)#ip nat outside (为该接口启用NAT )

router(config-if)#encapsulation ppp (为该接口封装PPP协议)

router(config-if)#dialer pool 1 (该接口使用1号拨号池进行拨号)

router(config-if)#dialer-group 1 (该命令对于pppoe是意义不大的)

router(config-if)#ppp authentication pap callin (启用ppp pap验证)

router(config-if)#$t-username fsDSL86257576@163.gd password 12345678

(使用已经申请的用户名和口令)

第四步:配置内部网络接口

router(config)#interface fastethernet0/0(配置内部网络接口)

router(config-if)#ip address 10.10.10.1 255.255.255.0(配置IP地址)

router(config-if)#ip nat inside(启用NAT)

第五步:配置CISCO路由器为内部网络主机提供dhcp服务

router(config)#ip dhcp excluded-address 10.10.10.1

router(config)#ip dhcp pool ABC (创建地址池)

router(dhcp-config)#import all (导入dns和wins server从运营商获取DNS等信息)

router(dhcp-config)#network 10.10.10.0 255.255.255.0

router(dhcp-config)#default-router 10.10.10.1

第六步:配置NAT:

router(config)#access-list 1 permit 10.10.10.0 0.0.0.255

router(config)#ip nat inside source list 1 interface dialer 1 overload

第七步:配置缺省路由

router(config)ip route 0.0.0.0 0.0.0.0 Dialer1

 

责任编辑:chenqingxiang 来源: IT实验室
相关推荐

2010-08-04 14:21:54

路由器配置

2009-12-24 10:30:28

路由器实现ADSL接入

2009-11-27 16:39:02

cisco 2500路

2011-08-29 14:45:15

路由器ADSL猫双路由连接

2010-08-06 10:33:32

思科路由器限速

2010-08-10 14:08:27

思科路由器OSPF协议

2010-08-06 10:21:38

路由器配置

2009-12-22 16:14:24

ADSL路由器设置

2011-08-11 15:24:51

2011-04-01 13:01:57

路由表路由器

2009-04-14 09:48:00

cisco路由器配置

2010-08-17 09:55:07

路由器技术

2010-08-04 09:00:38

路由器设置

2011-08-29 14:38:10

路由器ADSL猫双路由连接

2010-07-30 09:05:56

路由器设置

2009-11-17 13:37:23

2010-08-03 11:23:30

路由器

2009-12-22 15:57:18

Cisco路由器配置

2009-11-30 11:24:47

2009-12-11 15:21:15

华为路由器CISCO路由器
点赞
收藏

51CTO技术栈公众号