广播多路访问链路上的OSPF

网络 路由交换
文章主要用一个具体的实验向大家详细描述了如何实现OSPF技术,同时给详细的讲解了配置过程并且给出了配置命令。

本文主要从实验角度详细的描述了OSPF的配置全过程,让你在试验中深刻体会到配置OSPF的过程。

网络拓扑图:

实验目的:

1.在路由器上启动OSPF路由进程;

2.启用参与路由协议的借口,并且通告网络及所在的区域;

3.修改参考带宽;

4.DR选举的控制;

5.广播多路访问链路上的OSPF的特征。

实验步骤:

1.配置各路由器接口地址。

2.启动OSPF路由进程。

配置路由器R1

R1(config)#router ospf 1

R1(config-router)#router-id 1.1.1.1

R1(config-router)#network 1.1.1.0 255.255.255.0 area 0

R1(config-router)#network 192.168.11.0 255.255.255.0 area 0

R1(config-router)#auto-cost reference-bandwidth 1000

配置路由器R2

R2(config)#router ospf 1

R2(config-router)#router-id 2.2.2.2

R2(config-router)#network 2.2.2.0 255.255.255.0 area 0

R2(config-router)#network 192.168.11.0 255.255.255.0 area 0

R2(config-router)#auto-cost reference-bandwidth 1000

配置路由器R3

R3(config)#router ospf 1

R3(config-router)#router-id 3.3.3.3

R3(config-router)#network 3.3.3.0 255.255.255.0 area 0

R3(config-router)#network 192.168.11.0 255.255.255.0 area 0

R3(config-router)#auto-cost reference-bandwidth 1000

配置路由器R4

R4(config)#router ospf 1

R4(config-router)#router-id 4.4.4.4

R4(config-router)#network 4.4.4.0 255.255.255.0 area 0

R4(config-router)#network 192.168.11.0 255.255.255.0 area 0

R4(config-router)#auto-cost reference-bandwidth 1000#p#

实验调试

R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

4.4.4.4           1   FULL/DROTHER    00:00:35    192.168.11.4    FastEthernet0/0

3.3.3.3           1   FULL/DROTHER    00:00:36    192.168.11.3    FastEthernet0/0

2.2.2.2           1   FULL/BDR        00:00:35    192.168.11.2    FastEthernet0/0

以上输出表明在该广播多路访问网络中,R1是DR,R2是BDR,R3和R4是DROTHER。

〖技术要点〗

①为了避免路由器之间建立完全邻接关系而引起的大量开销,OSPF要求在多路访问的网络中选举一个DR,每个路由器都与之建立邻接关系。选举DR的同时也选举出一个BDR,在DR失效的时候,BDR担负起DR的职责,而且所有其他路由器只与DR和BDR建立邻接关系。

②DR和BDR有它们自己的组播地址224.0.0.6。

③DR和BDR的选举是以各个网络为基础的,也就是说,DR和BDR选举是一个路由器的借口特性,而不是整个路由器的特性。

④DR选举的原则:

●首要因素是时间,***启动的路由器被选举成DR;

●如果同时启动,或者重新选举,则看接口优先级(范围为0~255),优先级***的被选举成DR,在默认情况下,多路访问网络的接口优先级为1,点到点网络的接口优先级为0,修改接口优先级的命令是“ip ospf priority”,如果接口的优先级被设置为0,那么该接口将不参与DR选举;

●如果前两者相同,***看路由器ID,路由器ID***的被选举成DR。

⑤DR选举是非抢占的,除非人为地重新选举。重新选举DR的方法有两种,一是路由器重新启动;二是执行“clear ip ospf process”命令。

R1#debug ip ospf adj

R1#clear ip ospf process

R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

3.3.3.3           1   2WAY/DROTHER    00:00:39    192.168.11.3    FastEthernet0/0

2.2.2.2           1   FULL/DR         00:00:39    192.168.11.2    FastEthernet0/0

4.4.4.4           1   FULL/BDR        00:00:38    192.168.11.4    FastEthernet0/0

以上的输出表明:

1.DR重新选举的过程和结果,新的DR是R1,BDR是R4;

2.在OSPF邻接关系建立的过程中,接口状态的变化包括DOWN,2 Way,EXSTART,EXCHANGE,Loading和FULL。

备注:

auto-cost reference-bandwidth命令是用来修改参考带宽的。

DR指定路由器 (Designated Router)

BDR 备份指定路由器 (Backup Designated Router):一个OSPF网络中用来备份指定的路由器以防失效。
 

【编辑推荐】

  1. 常用思科路由器密码恢复经典案例
  2. 思科路由器口令恢复办法全解
  3. 思科路由器安全性管理
  4. cisco路由器配置ACL详解
  5. cisco路由器启动进程
责任编辑:chenqingxiang 来源: IT实验室
相关推荐

2011-04-13 16:33:29

OSPF

2011-04-13 16:40:02

OSPF

2009-09-02 13:01:11

C#多路广播

2014-09-10 09:49:49

OSPF

2021-05-07 13:42:58

区块链互联网技术

2011-04-01 11:32:09

OSPF

2022-04-05 12:59:07

源码线程onEvent

2010-05-26 15:37:02

IPv6地址类型

2017-04-24 12:00:43

2014-11-07 10:05:38

OSPFLSA

2011-09-29 15:28:14

通信展云手机移动

2021-01-28 19:45:48

区块链中心化分布式

2013-07-12 11:08:17

技术成长管理

2013-07-12 11:04:21

技术管理

2011-06-23 09:43:05

RADVISIONIPv6

2021-06-07 17:10:07

区块链出入口控制物联网

2013-11-28 10:05:24

OSPFLSA链路状态通告

2011-04-01 10:11:25

OSPF路由器

2010-09-17 08:24:59

敏捷开发

2012-09-24 10:06:13

般固banggoo
点赞
收藏

51CTO技术栈公众号