路由实用技巧 思科路由器如何限速

网络 路由交换
路由器是我们常用的网络设备,那么在使用的时候要怎样限制速度呢?具体要进行怎样的操作呢?下面的文章将给予你详细的解答。

本文主要针对思科路由器,详细的分析了思科路由器如何进行限速,要限制哪些服务呢?下面的文章将告诉你详细操作,并且给出了配置命令。

随着我国通信行业的发展,也推动了路由市场的需求量,这里主要针对思科路由器,详细的分析了思科路由器如何限速,大家都知道如果要限制某项服务,就要在路由器上设置ACL(访问控制列表)将该服务所用的端口封掉,从而阻止该服务的正常运行。对BT软件,我们可以尝试封它的端口。一般情况下,BT软件使用的是6880-6890端口,在公司的核心思科路由器上使用以下命令将6880-6890端口全部封锁。

限速:

access-list 130 remark bt

access-list 130 permit tcp any any range 6881 6890

access-list 130 permit tcp any range 6881 6890 any

rate-limit input access-group 130 712000 8000 8000 conform-action transmit exceed-action drop

rate-limit output access-group 130 712000 8000 8000 conform-action transmit exceed-action drop

禁止下载:

access-list 130 deny tcp any any range 6881 6890

access-list 130 deny tcp any range 6881 6890 any

ip access-group 130 in / out

不过现在的bt软件,再封锁后会自动改端口,一些软件还是用到8000、8080、2070等端口,限制这些端口这样网络不正常!第二种方法是使用NVAR(Network-Based Application Recognition,网络应用识别)。NBAR (Network-Based Application Recognition) 的意思是网络应用识别。 NBAR 是一种动态能在四到七层寻找协议的技术,它不但能做到普通 ACL 能做到那样控制静态的、简单的网络应用协议 TCP/UDP 的端口号。例如我们熟知的 WEB 应用使用的 TCP 80 ,也能做到控制一般 ACLs 不能做到动态的端口的那些协议,例如 VoIP 使用的 H.323, SIP 等。

要实现对 BT 流量的控制,就要在思科路由器上实现对 PDLM 的支持。 PDLM 是 Packet Description Language Module 的所写,意思是数据包描述语言模块。它是一种对网络高层应用的协议层的描述,例如协议类型,服务端口号等。它的优势是让 NBAR 适应很多已有的网络应用,像 HTTP URL , DNS , FTP, VoIP 等 , 同时它还可以通过定义,来使 NBAR 支持许多新兴的网络应用。例如 peer2peer 工具。 PDLM 在思科的网站上可以下载,并且利用 PDLM 可以限制一些网络上的恶意流量。CISCO在其官方网站提供了三个PDLM模块,分别为KAZAA2.pdlm,bittorrent.pdlm.emonkey.pdlm可以用来封锁KAZAA,BT,电驴得到PDLM然后通过TFTP服务器将 bittorrent.pdlm 拷贝到路由中。利用ip nbar pdlm bittorrent.pdlm命令将NBAR中的 BT 功能启动。再创建一个 class-map 和 policy map 并且把它应用到相应的思科路由器的接口上。一般是 连接 Internet (Chinanet ) 的接口是 FastEthernet 或 10M 的以太网接口。在思科路由器上您可以看见如下的配置 :

class-map match-all bittorrent

match protocol bittorrent

!

!

policy-map bittorrent-policy

class bittorrent

drop

!

interface FastEthernet0/

description neibujiekou

ip address 192.168.0.1 255.255.255.0

ip nat inside

service-policy input bittorrent-policy

service-policy output bittorrent-policy

!

这样您就可以在你的公司或单位的因特网接入思科路由器上实施一些流量控制。同时NBAR和PDLM还可以应用在您公司和单位的内联广域网上,可以保证广域网带宽的合理使用。
 

【编辑推荐】

  1. 常用思科路由器密码恢复经典案例
  2. 思科路由器口令恢复办法全解
  3. 思科路由器安全性管理
  4. cisco路由器配置ACL详解
  5. cisco路由器启动进程
责任编辑:chenqingxiang 来源: IT168
相关推荐

2010-08-04 10:26:24

路由器

2009-12-03 14:16:36

思科路由器

2010-08-13 10:24:03

思科路由器限速

2010-08-06 10:33:32

思科路由器限速

2011-09-08 11:15:51

思科路由器如何限速路由器设置思科路由器

2011-09-14 17:16:14

2011-08-15 13:41:41

2010-11-04 10:25:47

思科路由器限速

2011-09-05 14:31:20

路由器限速

2009-12-23 17:32:35

Linux构建软路由

2009-11-17 11:08:30

思科路由器配置

2010-08-17 08:55:11

无线路由器掉线问题

2010-08-11 15:44:26

无线路由器掉线

2010-08-13 11:06:24

2010-07-30 14:30:36

2011-08-11 14:36:49

2009-12-03 11:19:39

路由器设置路由器限速

2011-08-11 15:24:51

2009-12-11 16:42:41

思科路由器

2011-09-05 11:24:26

Cisco路由器限速CEF
点赞
收藏

51CTO技术栈公众号