cisco技术大集合——路由重新分配技术

网络 路由交换
本文详细的讲述了路由重分配技术的基本配置,同时讲述了OSPF和RIP技术的应用,在下面的文章中给出了详细的介绍。

本文详细的讲述了路由重分配技术的基本配置,同时讲述了OSPF和RIP技术的应用,在下面的文章中给出了详细的介绍。

在实际工作中,我们会遇到使用多个IP路由协议的网络。为了使整个网络正常地工作,必须在多个路由协议之间进行成功的路由再分配。

以下列举了OSPF与RIP之间重新分配路由的设置范例:

Router1的Serial 0端口和Router2的Serial 0端口运行OSPF,在Router1的Ethernet 0端口运行RIP 2,Router3运行RIP2,Router2有指向Router4的192.168.2.0/24网的静态路由,Router4使用默认静态路由。需要在Router1和Router3之间重新分配OSPF和RIP路由,在Router2上重新分配静态路由和直连的路由。

范例所涉及的命令

任务 命令

重新分配直连的路由 redistribute connected

重新分配静态路由 redistribute static

重新分配ospf路由 redistribute ospf process-id metric metric-value

重新分配rip路由 redistribute rip metric metric-value

Router1:

interface ethernet 0

ip address 192.168.1.1 255.255.255.0

!

interface serial 0

ip address 192.200.10.5 255.255.255.252

!

router ospf 100

redistribute rip metric 10

network 192.200.10.4 0.0.0.3 area 0

!

router rip

version 2

redistribute ospf 100 metric 1

network 192.168.1.0

!

Router2:

interface loopback 1

ip address 192.168.3.2 255.255.255.0

!

interface ethernet 0

ip address 192.168.0.2 255.255.255.0

!

interface serial 0

ip address 192.200.10.6 255.255.255.252

!

router ospf 200

redistribute connected subnet

redistribute static subnet

network 192.200.10.4 0.0.0.3 area 0

!

ip route 192.168.2.0 255.255.255.0 192.168.0.1

Router3:

interface ethernet 0

ip address 192.168.1.2 255.255.255.0

!

router rip

version 2

network 192.168.1.0

!

Router4:

interface ethernet 0

ip address 192.168.0.1 255.255.255.0

!

interface ethernet 1

ip address 192.168.2.1 255.255.255.0

!

ip route 0.0.0.0 0.0.0.0 192.168.0.2

!

 

【编辑推荐】

  1. 常用思科路由器密码恢复经典案例
  2. 思科路由器口令恢复办法全解
  3. 思科路由器安全性管理
  4. 概述思科路由器密码恢复原理
  5. 配置CBAC,提升Cisco路由器安全
责任编辑:chenqingxiang 来源: IT实验室
相关推荐

2012-12-26 17:14:03

2010-02-03 09:53:08

Python版本

2012-04-28 10:29:24

jQuery

2009-12-22 11:30:02

宽带路由器性能

2010-07-26 09:06:09

SQL Server游

2011-07-04 10:33:22

QT

2010-07-14 14:02:52

SQL Server数

2012-01-05 10:19:43

JavaScript

2014-05-15 15:29:09

Android开发资源

2011-06-21 10:44:32

QT QTE

2013-08-13 13:38:13

Android错误解决

2010-10-20 17:31:40

Fedora应用

2010-06-09 17:00:43

UML试题

2010-02-24 10:52:24

IBM中端服务器

2015-06-29 10:08:44

2010-08-06 10:50:58

2009-08-24 11:04:56

2010-10-12 14:28:54

2018-12-17 09:00:00

大数据数据科学工具

2014-06-12 17:02:46

世界杯手游
点赞
收藏

51CTO技术栈公众号