Cisco路由器配置命令全面概括

网络 路由交换
文章主要针对思科路由器,讲解了常用的Cisco路由器配置命令,让您对Cisco路由器配置命令有一个更加深刻的了解,同时在以后的使用中更加的方便。

其实很多品牌的路由器配置命令都很相似,所以文章主要针对思科路由器,全面的分析了常用的Cisco路由器配置命令,希望对您有所帮助,同时也学习到更多的知识。

Cisco路由器配置命令之交换机基本状态:

switch: ;ROM状态
hostname# ;特权模式
hostname(config)# ;全局配置模式
hostname(config-if)# ;接口状态
enable ;进入特权模式
switch#config terminal ;进入全局配置模式
switch(config)#hostname  ;设置交换机的主机名
switch(config)#enable secret xxx ;设置特权加密口令
switch(config)#enable password xxa ;设置特权非密口令
switch(config)#line console 0 ;进入控制台口
switch(config-line)#line vty 0 4 ;进入虚拟终端
switch(config-line)#login ;允许登录
switch(config-line)#password xx ;设置登录口令
xxswitch#exit ;返回命令
 
Cisco路由器配置命令之交换机VLAN设置:

switch#vlan database ;进入VLAN设置
switch(vlan)#vlan 2 ;建VLAN 2
switch(vlan)#no vlan 2 ;删
vlan 2switch(config)#int f0/1 ;进入端口1
switch(config-if)#switchport access vlan 2 ;当前端口加入
vlan 2switch(config-if)#switchport mode trunk ;设置为干线
switch(config-if)#switchport trunk allowed vlan 1,2 ;设置允许
vlanswitch(config-if)#switchport trunk encap dot1q ;设置vlan 中继
switch(config)#vtp domain  ;设置发vtp域名
switch(config)#vtp password  ;设置发vtp密码
switch(config)#vtp mode server ;设置发vtp模式
switch(config)#vtp mode client ;设置发vtp模式
 
Cisco路由器配置命令之交换机设置IP地址:

switch(config)#interface vlan 1 ;进入
vlan 1switch(config-if)#ip address   ;设置IP地址
switch(config)#ip default-gateway  ;设置默认网关
switch#dir flash: ;查看闪存
 
Cisco路由器配置命令之交换机显示命令:

switch#write ;保存配置信息
switch#show vtp ;查看vtp配置信息
switch#show run ;查看当前配置信息
switch#show vlan ;查看vlan配置信息
switch#show interface ;查看端口信息
switch#show int f0/0 ;查看指定端口信息   
router#copy running-config startup-config ;保存配置
router#copy running-config tftp ;保存配置到
tftprouter#copy startup-config tftp ;开机配置存到
tftprouter#copy tftp flash: ;下传文件到
flashrouter#copy tftp startup-config;下载配置文件ROM状态:
Ctrl+Break ;进入ROM监控状态
rommon>confreg 0x2142 ;跳过配置文件
rommon>confreg 0x2102 ;恢复配置文件
rommon>reset  ;重新引导
rommon>copy xmodem: flash: ;从console传输文件
rommon>IP_ADDRESS=10.65.1.2 ;设置路由器IP
rommon>IP_SUBNET_MASK=255.255.0.0 ;设置路由器掩码
rommon>TFTP_SERVER=10.65.1.1 ;指定TFTP服务器IP
rommon>TFTP_FILE=c2600.bin ;指定下载的文件
rommon>tftpdnld ;从tftp下载
rommon>dir flash: ;查看闪存内容
rommon>boot ;引导IOS

Cisco路由器配置命令之静态路由配置:

ip route;命令格式
router(config)#ip route 2.0.0.0 255.0.0.0 1.1.1.2 ;静态路由举例
router(config)#ip route 0.0.0.0 0.0.0.0 1.1.1.2 ;默认路由举例

Cisco路由器配置命令之动态路由配置:

router(config)#ip routing ;启动路由转发
router(config)#router rip ;启动RIP路由协议。
router(config-router)#network  ;设置发布路由
router(config-router)#negihbor  ;点对点帧中继用。
 
 

责任编辑:王晓东 来源: QQRead
相关推荐

2009-12-02 15:58:55

Cisco路由器配置命

2009-12-01 10:35:50

Cisco 路由器VP

2012-03-20 10:05:57

Cisco路由器路由器DNS

2009-11-11 17:07:13

路由器故障

2009-12-17 14:01:46

2009-12-01 17:29:02

路由器配置DHCP

2009-11-23 17:25:44

Cisco路由器端口

2010-04-14 16:37:12

Cisco路由器

2009-11-11 13:16:02

2009-12-17 13:53:50

Cisco路由器安全配

2009-04-14 09:48:00

cisco路由器配置

2009-11-26 09:56:39

Cisco路由器配置命交换机配置命令

2010-08-26 09:55:25

Cisco路由器DHCP

2009-12-16 15:56:05

Cisco路由器配置

2009-11-13 14:22:07

路由器设置

2012-03-02 14:17:03

2011-04-01 16:03:18

IOS路由器

2010-08-06 10:21:38

路由器配置

2010-08-03 11:35:06

2010-07-30 15:59:44

配置
点赞
收藏

51CTO技术栈公众号