CCNP:主机备份路由协议(HSRP)的配置

企业动态
热备份路由协议是HSRP(Hot standby router protocol)是cisco平台所特有的一种技术,它确保了当网络边缘设备或接入链路出现故障时,用户通信迅速并透明地恢复,并以此为IP网络提供冗余性,通过应用HSRP,可使网络的正常运行时间接近100%,从而满足用户对网络可靠性的要求。

热备份路由协议是HSRP(Hot standby router protocol)是cisco平台所特有的一种技术,它确保了当网络边缘设备或接入链路出现故障时,用户通信迅速并透明地恢复,并以此为IP网络提供冗余性,通过应用HSRP,可使网络的正常运行时间接近100%,从而满足用户对网络可靠性的要求。

热备份路由协议为IP我网络提供了容错和增强的路由选择功能。通过使用同一个虚拟IP地址和虚拟MAC地址,LAN网络上的两台或多台路由器可以作为一台“虚拟”路由器而对外提供服务。HSRP使组内cisco路由器能互相监视对方的运行状态:

(1) 虚拟路由器组的成员通过HSRP消息不断地交换状态信息。

(2) 如果其中一台出现故障,另一台就能接替它,继续完成路由功能。

LAN 网段上的主机都配置只用同一个虚拟路由器作为默认网关,并不断将IP包发往同一个IP和MAC地址。因此,理由设备的切换对主机就是透明的。绝大多数主机路由表相对简单,并且以默认网关作为唯一的吓一跳IP和MAC地址。HSRP向主机提供了默认网关的冗余性,减少了主机维护路由表的任务。另外通过多个热备份组,路由器可以提供冗余备份,并在不同的IP子网实现负载分担。

具体配置:

  RA:

  Router>enable

  Router#config t

  Router(config)#hostname RA

  RA(config)#no ip domain-lookup

  RA(config)#line con 0

  RA(config-line)#no exec-t

  RA(config-line)#exit

  RA(config)#interface e0/2

  RA(config-if)#ip address 10.10.10.1 255.255.255.0

  RA(config-if)#no sh

  RA(config-if)#du fu

  RA(config-if)#standby 10 ip 10.10.10.254

  RA(config-if)#standby 10 priority 110

  RA(config-if)#standby 10 preempt

  RA(config-if)#exit

  RA(config)#interface e0/1

  RA(config-if)#ip address 172.16.10.1 255.255.255.0

  RA(config-if)#no sh

  RA(config-if)#du fu

  RA(config-if)#standby 172 ip 172.16.10.254

  RA(config-if)#standby 172 priority 120

  RA(config-if)#standby 172 preempt

  RA(config-if)#no sh

  RA(config-if)#end

  RA#

  RB:

  Router>enable

  Router#config ter

  Router(config)#hostname RB

  RB(config)#no ip domain-lookup

  RB(config)#line con 0

  RB(config-line)#no exec-t

  RB(config-line)#exit

  RB(config)#interface e0/2

  RB(config-if)#ip address 10.10.10.2 255.255.255.0

  RB(config-if)#no sh

  RB(config-if)#du fu

  RB(config-if)#standby 10 track ethernet 0/1 100

  RB(config-if)#standby 10 ip 10.10.10.254

  RB(config-if)#standby 10 priority 120

  RB(config-if)#standby 10 preempt

  RB(config-if)#no sh

  RB(config-if)#exit

  RB(config)#interface e0/1

  RB(config-if)#ip address 172.16.10.2 255.255.255.0

  RB(config-if)#no sh

  RB(config-if)#du fu

  RB(config-if)#standby 172 ip 172.16.10.254

  RB(config-if)#standby 172 priority 110

  RB(config-if)#standby 172 preempt

 

【编辑推荐】

  1. 思科认证专区
  2. CCNP:HSRP介绍及校园网的应用
  3. CCNP课堂—PBR+SLA配置实例
责任编辑:夏雨 来源: www.56cto.com
相关推荐

2010-06-12 14:40:53

热备份路由协议HSRP

2010-07-12 15:59:33

HSRP路由协议

2009-05-13 09:39:24

2011-04-13 11:33:37

HSRP

2015-04-16 09:20:02

动态路由协议RIP

2009-11-11 17:28:42

HSRP路由协议

2009-05-13 10:06:42

2011-08-11 15:14:30

2009-11-20 16:33:02

备份路由器

2013-08-05 09:22:16

网络协议DHCP协议DHCP

2010-07-08 14:51:34

路由选择协议

2010-08-19 13:42:08

路由器备份

2011-08-16 11:22:09

EIGRP帧中继

2010-08-06 10:55:50

配置RIP路由协议

2009-12-23 15:00:15

正确配置路由协议

2009-11-24 14:52:00

CCNP协议

2009-11-26 15:51:00

CCNP路由

2009-04-14 09:48:00

cisco路由器配置

2009-12-14 17:32:46

路由选择协议

2010-08-06 09:24:07

RIP路由协议
点赞
收藏

51CTO技术栈公众号