浅析MySQL-5.1.x在RH5上安装报错的问题

数据库 MySQL
在RE5(Red Hat红帽)系统上安装MySQL-5.1.x可能会出现一些错误,本文是作者在实际工作中碰到的一些问题的解决方法。

客户要求mysql-5.1.32是gbk的版本

我从mysql.com下载了二进制源码,不用编译自己安装就好了。后来查看到是latin1的语言~

网上搜索了半天,一篇有用的文章也没有,都是在freebsd下如何重新安装mysql-5.1.32,让他支持gbk

不得已。又搜索了下找到了mysql5.1.32的源码包,还是手动编译自己心里放心~

从这里下载http://dev.mysql.com/downloads/mysql/5.1.html  mysql5.1.32.tar.gz

至于如何支持gbk,还是默认的--with-charset=gbk --with-xcharset=all

最主要是安装好后出现问题,启动时候出错,查看error

/usr/local/mysql5/libexec/mysqld: Table 'mysql.plugin' doesn't exist

090224 23:30:42 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.

090224 23:30:42 [ERROR] /usr/local/mysql5/libexec/mysqld: unknown option '--skip-federated'

090224 23:30:42 [ERROR] Aborting

090224 23:30:42 [Note] /usr/local/mysql5/libexec/mysqld: Shutdown complete

解决方法

my.cnf里注释掉--skip-federated新版本不需要这个参数了。如果需要这个引擎的在编译的时候要加上
--with-plugins=federated,在my.cnf里用federated参数就行了。

【编辑推荐】

  1. 实战PHP5+Apache2.2+MySQL5.1配置经历
  2. MySQL性能优化实战
  3. 优化MySQL插入方法的五个妙招
责任编辑:彭凡 来源: 新浪博客
相关推荐

2010-05-12 15:16:46

MySQL 5.1

2011-04-08 10:10:23

2012-10-31 09:51:05

Mac OS XLua编程

2010-06-10 16:00:23

MySQL 5

2009-07-10 18:02:05

MyEclipseMySQL

2019-04-28 10:00:11

UbuntuLinuxMySQL

2009-03-10 10:53:42

安装ApacheMySQL

2020-10-22 16:29:32

LinuxMariaDBMySQL

2009-09-03 13:50:31

AudacityRHEL5源码编译

2010-05-20 15:15:59

MySQL Serve

2021-02-03 05:23:20

监控

2022-12-01 11:41:24

2009-07-26 09:03:17

CentOS 5.1编译Erlang-R12B

2011-05-16 10:04:38

2022-02-16 23:04:26

XtrabackupMySQLPercona

2009-06-04 09:47:48

MySQL隐藏控件TMPDIR

2022-12-02 11:37:47

2011-08-29 17:27:47

HTML 5交互移动应用

2011-03-14 15:12:27

iptables安装

2010-05-13 10:09:18

MySQL编码
点赞
收藏

51CTO技术栈公众号