实战:组建超完美的内网专线VOIP通信

网络
VOIP技术已经出现多年,技术实现方案非常成熟,但是国外大牌公司的实现方案大都非常昂贵,很难在我国形成普及的局面。如今这种局面出现了可喜的变化,众多国内网络厂商纷纷推出自己的VOIP组网设备,实现方案更简单,总体成本是国外产品的1/3-1/2,这唤醒了国内大企业、大行业客户、政府机构的IP电话组网热情。

网络结构:要求14个分点实现VOIP通话

本文将介绍笔者参与建设的某省级国家统计局基于迈普方案的VOIP组网方案。该方案要求全省14个市的统计局与省机关实现全面VOIP通话,当然各单位内部也能实现各自的VOIP通话,该方案的网络拓朴如下:

(图1插入位置)  

我们可以看到这个VOIP语音方案对原有网络结构是不做任何改动的,网络配置也不需要做任何改动,只需要在语音语关上做是相关配置,若原电话布线系统不健全,可能需要进行桌面电话集中到网络中心的电话布线。在这个方案中,VOIP电话系统利用现在的统计局专线网络与各市局相连,然后各市局机关VOIP电话系统连接到现有办公局域网就可以了。网络结构非常简单。#p#

组网设备:语音网守和语音网关

迈普VOIP语音组网方案需要两种关键的语音设备,分别是:语音网守和语音网关。

(一)语音网守  

IP电话网守是H.323 VoIP系统方案的关键设备,负责实现地址解析、接入认证和带宽管理等核心控制功能。网守最重要的功能是地址解析,它在它的路由表中查找目的网关的IP地址,如果目的网关不在本区域中,向上级网守或邻近网守请求在别的区域(一个网守就是一个“区域”)中查找。找到目的网关后返回对应网关的IP地址,这样就可以跨语音网关通话。迈普MyPower VGK2X系列IP电话网守由VGK2X和VGK2X-B两个型号构成,基于专用嵌入式结构设计,采用迈普带宽控制、聪明路由等专有技术,具有安全可靠、功能强大、组网灵活等特点,适用于组建各类规模的H.323 VoIP网络,或者多协议的VoIP协作通信网络。  

本方案采用的是一台VGK2X(图2)网守部署在省局,各市局语音网关在其上注册,最终实现各市局跨语音网关远程通话。  

(二)语音网关  

迈普语音网关MyPower VG系列包括:VG M6000、VG2000、VG800和VG A600四个型号,与迈普VGK2X系列网守配合使用,可为用户构建以VoIP为基础的网络语音通信平台。  

MyPower VG系列语音网关同时支持成熟的H.323协议和先进的SIP协议,采用迈普专有通话质量提升技术,包括静音压缩及舒适噪声、回波抵消功能、动态JitterBuff调整和丢包补偿等机制,提供可与传统PSTN相媲美的高品质通话。并采用迈普特有的“聪明路由”,能够动态地为当前呼叫选择最佳路径,即使在IP网络阻塞和单点设备故障等异常情况下,也能够为用户提供高品质的通话。“1:1绑定”技术,可以实现VOIP电话与原有PSTN电话一对一绑定,能够完全不改变用户的原有电话号码和拨打习惯,并且在单点设备掉电等异常情况下,也能够为用户提供PSTN通话,保证电话永远不会出现断路。这样,使用电话的用户完全不会感觉得到他或她在打的电话是经过VOIP还是普通市话。但本方案中,采用的是“纯”的IP电话,语音网关没有接入PSTN线路,因此没有做“1:1绑定”。 MyPower VG系列语音网关还支持PSTN附加业务和特色增值业务,极大提升VoIP系统价值,包括:电话会议,群组振铃,呼叫代答,来电显示,呼叫转接,呼叫等待,热线拨号,IVR录音等增值功能。  

在本方案中,在省局机关采用两台MyPower VG M6000来实现大容量的电话接入,分别是64门和94门;在各市局采用MyPower  VG 2000来实现16~32门的电话接入。     

MyPower VG M6000是核心级语音网关,采用全模块化设计,支持接入端口类型、端口数量和处理能力的按需配置,支持板卡热插拔、双电源冗余、“1:1绑定组网”和“掉电逃生”,也就是语音网关掉电时,一样可以打电话。最大可以提供4路E1中继(用来接入外线电话)和96线模拟接入(用来接到桌面普通电话机)。  

MyPower VG2000是地市级语音网关,采用全模块化设计,支持业务端口类别、端口数量和处理能力的按需配置,最大提供1路E1中继和32线模拟接入或提供48线模拟接入。#p#

如何进行号码规划方案

有两种号码规划方法:一种是纯的VOIP电话方案,自定义本单位内部的VOIP电话号码;另一种是使用原有的电信市话号码做为VOIP电话的电话号码,并做“1:1绑定”。  

方案1:自定义VOIP电话号码方案  

这种方案一般使用三位或四位数字来规划,号码随意制订。上面已经提到过本方案是“纯”的VOIP电话组网,也就是没有接入市话线路,因此不需跟市话号码做“1:1绑定”。若做“1:1绑定”,我们一般采用市话的号码来规划VOIP号码,这样方便记忆和操作。在这里不需绑定市话号码,所以采用自定义三位(数字)小号,在前面加各市区号来组合成VOIP电话号码,本地(指语音网关内部)通话直拨小号,跨市局通话,前面加拨区号,由网守来路由。  

这种方案只使用模拟接入板卡模块(FXS卡),用来接入普通桌面电话机。  

方案2:使用原有电信市话号码来作为对应的VOIP电话号码  

这种方案使用桌面电话的原有电信市话号码作为内部VOIP电话的号码,这样最终使用电话的用户还是按照原来拨号方式打电话,他(她)并不知在打的电话是经过IP网络还是经过电信公司的市话线路。在VOIP网络通畅时,电话是优先经过VOIP链路通话的,只有在VOIP出现故障或打外线电话时,才会通过电信公司市话线路通话。

这种方案除了使用模拟接入板卡模块(FXS卡),用来接入普通桌面电话机,还要使用VOS卡或E1中继模块来接入电信市话,这样在打外线、VOIP线路不通或者语音网关掉电的情况下,均可以用市话正常通话。

设备链接配置

迈普的这套VOIP语音方案只适合在已经部署了完善的内网专线上运行,语音网关和语音网守的安装都非常简单。只要保证专线内网的路由是通的,没有做限制VOIP所使用的IP地址和端口的访问控制列表,中间经过的防火墙没有对VOIP所使用的IP地址、端口、协议等参数做了限制就可以了。在本工程中,笔者遇到的拦路虎很多都是各种不同品牌的防火墙对VOIP系统的限制,有时是无法理解的,明明似乎是对VOIP全放开了,网络能PING得通,但VOIP电话就是不通。这需要网络工程师和网管人员用心来研究防火墙的设置问题。实际工程中,经常是绕过防火墙就没有问题,一经过防火墙就可能出现注册不上网守或通话不正常的情况。  

物理连接:

(1) 网络部分,只需将语音网关和网守的以太网口接入局域网交换机的交换口就行了。

(2) 桌面电话过来的电话线应打在标准的RJ45配线架或者110配线架上,然后使用相应接口的电话跳线接到语音网关的模拟卡上对应号码的RJ11接口上。语音网关若需接入市话线路的,就将来自电信公司的电话线接在VOS卡的RJ11接口上即可。#p#   

配置模板

(1)VGK 2X 网守配置模板

vgk2X#sh run

Building Configuration...done

Current configuration: 430 bytes

version 3.0.24(gatekeeper)

hostname vgk2X

enable password OWRW[WWW\W encrypt

no service password-encrypt

no service enhanced-secure

interface loopback0

exit

interface fastethernet0  

ip address 10.45.99.231 255.255.255.0  // 配置以太网口IP

exit

ip route 0.0.0.0 0.0.0.0 10.45.99.1 // 配置默认路由

gatekeeper

time-to-live min 120

zone local maipu maipu.com 10.45.99.231 // 配置网守ID为maipu,区域名为maipu.com,IP为10.45.99.231

time-stamp difference 30

no shutdown

exit

License AA2E1FCD-E14DF946-F91E276E-65704E11

gatekeeper exit#p#     

(2)VG M6000语音网关(VG2000相同)配置模板

vg6000 #sh run

Building Configuration...done

software version 8.0.42

software image file VPM6000-VG-8.0.42.bin

compiled on Jan 14 2008, 09:49:07

hostname vg6000

no service password-encrypt

no service new-encrypt

no service enhanced-secure

service login-secure                   

enable password OWRW[WWW\W encrypt

ip name-order local-first

interface loopback0

exit

interface fastethernet1   

ip address 10.45.103.232 255.255.255.0  // 配置以太网口的IP地址

exit        

ip route 0.0.0.0 0.0.0.0 10.45.103.1  // 配置默认路由

callrouting-conf

dial-peer 10 pots slot 1   // 配置1槽的大号“拨号端”,下同

channel 0 2 destination-pattern 0771601 increase

channel 3 11 destination-pattern 0771605 increase

channel 12 20 destination-pattern 0771615 increase

channel 21 29 destination-pattern 0771625 increase

channel 30 31 destination-pattern 0771635 increase

exit

dial-peer 20 pots slot 2

channel 0 2 destination-pattern 0771637 increase

channel 3 6 destination-pattern 0771650 increase

channel 7 15 destination-pattern 0771655 increase

channel 16 24 destination-pattern 0771665 increase

channel 25 31 destination-pattern 0771675 increase

exit

dial-peer 30 pots slot 3

channel 0 1 destination-pattern 0771682 increase

channel 2 10 destination-pattern 0771685 increase

channel 11 19 destination-pattern 0771695 increase

channel 20 28 destination-pattern 0771705 increase

channel 29 31 destination-pattern 0771715 increase

exit

dial-peer 11 pots slot 1    // 配置1槽的小号“拨号端”,下类似

channel 0 2 destination-pattern 601 increase

channel 3 11 destination-pattern 605 increase

channel 12 20 destination-pattern 615 increase

channel 21 29 destination-pattern 625 increase

channel 30 31 destination-pattern 635 increase

channel 0 31 register disable

exit

dial-peer 21 pots slot 2

channel 0 2 destination-pattern 637 increase

channel 3 6 destination-pattern 650 increase

channel 7 15 destination-pattern 655 increase

channel 16 24 destination-pattern 665 increase

channel 25 31 destination-pattern 675 increase

channel 0 31 register disable

exit

dial-peer 31 pots slot 3

channel 0 1 destination-pattern 682 increase

channel 2 10 destination-pattern 685 increase

channel 11 19 destination-pattern 695 increase

channel 20 28 destination-pattern 705 increase

channel 29 31 destination-pattern 715 increase

channel 0 31 register disable

exit

dial-peer 1 voip   // 配置跨区号拨打的,向网守查找

destination-pattern xx.

session-target  ras

exit

dial-peer 2 voip   // 配置同区号的拨打9开头的小号的,向IP是10.45.91.232的语音网关查找(下类似)

destination-pattern 9xx

session-target  10.45.91.232

exit

dial-peer 3 voip

destination-pattern 8xx

session-target  10.45.99.232

exit

dial-peer 4 voip

destination-pattern 2xx

session-target  10.45.1.232

exit

dial-peer 5 voip

destination-pattern 3xx

session-target  10.45.14.232
exit

exit

card 0

exit

card 1

channel 0 31 callid enable  // 来电功能打开

channel 0 31 enable       // 开启“通道”,下类似

exit

card 2

channel 0 31 callid enable

channel 0 31 enable

exit

card 3

channel 0 3 callid enable

channel 0 31 enable

exit

sys-clock-source specify local

voicesrv-conf

black-white-list

exit

fax-protocol t38

h323 start slow

h323 send-dtmf h245-string

h323 call-diversion default

h323 h245Tunnel off

h323 bearer-cap 3100hz

h323 fill-send-complete enable

h323 grq_interval 40

h323 call-thrust-ttl 10call-transfer enable   // 打开呼叫转移功能 call-transfer consultation

user-config enable

exit       

gateway  // 向网守注册

interface fastethernet1 h323-gateway voip h323-id vg6000 // 配置本语音网关ID为vg6000 h323-gateway voip id maipu ipaddr 10.45.99.231 1718 // 网守ID为maipu,及网守IP10.45.99.231及网守端口号1718 h323-gateway voip interfaceexit

line vty 0 4 password 0 admin login exit

总结:迈普VOIP方案的安装部署非常简单,几乎不用做原有专线内网的任何改造。配置命令也不复杂,关键位置也只有少数几句而已。迈普语音方案具有极高的性价比优势,组网以后,本系统单位内部的电话将全面实现免费通话。本语音方案非常适合具有专线内网的单位实施。

【编辑推荐】

  1. 企业VoIP的实现方式与网络组织
  2. 基于高速公路通信网的VoIP实现及应用
责任编辑:许凤丽 来源: IT168
相关推荐

2009-09-11 09:36:53

李开复

2020-10-26 09:53:44

Dropbox攻击网络安全

2022-03-29 08:55:18

存储引擎核心

2020-10-23 10:36:08

Dropbox

2013-03-04 09:51:00

VoIP通信网络统一通信

2010-05-25 17:32:59

无线VoIP

2014-03-25 09:15:20

VS2012GitHub

2022-03-02 09:49:14

Rust编程语言

2019-05-15 09:00:00

决策树机器学习人工智能

2009-12-15 10:47:29

linux操作系统

2010-06-18 10:51:27

NetBeans 6.CSSEclipse

2013-06-24 13:51:47

手机用户体验移动应用移动互联网市场

2010-03-18 14:11:32

Web交换机

2018-02-23 13:26:04

2010-03-02 17:47:15

Android手机操作

2010-03-05 17:30:25

Android手机操作

2013-10-15 17:37:16

XToolscrm

2022-02-15 12:14:49

人工智能数据优化

2010-11-30 09:40:15

流量控制设备AllotQOS策略

2021-03-05 10:13:45

Python 开发编程语言
点赞
收藏

51CTO技术栈公众号